0

Loading package with rvpkg

Hi all!

I know that when you create a new package in the PACKAGE file you can set that the mode has to be loaded inmediately or not but this works the first time. If the package is already installed but it has unchecked the "Load" checkbox there is no way to force to load the package via the rvpkg command, you have to go to the RV Preferences -> Packages and do it there.

Is there a way to force the load a package that is already installed with the rvpkg command?

Thanks a lot!

2 条评论

  • Avatar
    Jon Morley 正式评论

    Hi Raul,

    The rvpkg command only operates on RV's internal package installation configuration. Packages can be optional or not and that is what the rvpkg command changes. It does not change any package related preferences. If a user decides to unload a package in their personal preferences it will be unloaded.

    If you do not trust your users to set their package preferences you can use the nuclear option with the RV_PREFS_CLOBBER_PATH environment variable to forcibly set the prefs for what packages they load and don't load. This option is not additive. It will completely wipe out whatever they have set as well as the ability for them to have any personal package settings. Please read more about the RV's hierarchical preferences here:

    http://tweaksoftware.com/static/documentation/rv/current/html/rv_reference.html#Chapter_15_Hierarchical_Preferences

    Thanks,
    Jon

  • 0
    Avatar
    Raul Catalina

    I do understand, I will take a look at this, it could be helpful.

    Thank you Jon!

请先登录再写评论。