0

How to turn off color correction and conversion

What is the best way to set 

View->"No Correction"

Color->"No Conversion"

as the default for all files, without having to set it manually for each merged file?

Using RV 4.0.12

Thanks!

 

15 条评论

  • 0
    Avatar
    Enoch Davis

    Asking because I've seen multiple forum threads w/slightly different answers re: using source_setup scripts/custom LUT packages, etc. 

  • 0
    Avatar
    Jon Morley

    Hi Enoch,

    There are a couple of approaches to handling this. Choosing the best option depends on what media you are looking at and why you want to modify the default color management behavior.

    It is very rare that users would want to disable both the source linearization as well as the display correction for all files all the time. Please tell us more about your situation and why you have arrived at this and I can help you find the best solution.

    It is true that making a custom soruce_setup, or using the Custom LUT Package are both approaches that give this kind of control. However you can also set the environment variable RV_OVERRIDE_TRANSFER_<extension> to individually control how each extension is treated.

    In any case please tell us more about your usage case and we can help narrow it down from there.

    Thanks,
    Jon

  • 0
    Avatar
    Enoch Davis

    I am loading .dpx and .sgi image sequences created by our artists. Our VFX supervisor needs to see them with Color->"No Conversion" and View->"No Correction" by default, but they come in with "sRGB" selected. 

     

  • 0
    Avatar
    Enoch Davis

    Correction-- loading in .tga (targa) as well as .dpx and .sgi image sequences

  • 0
    Avatar
    Enoch Davis

    We load in 2 versions of each image sequence: Our color-corrected versions are .tga's or .sgi's, and our non-cc versions are .dpx's. We want to view all these image sequences with "No Conversion" and "No Correction."

  • 0
    Avatar
    Jon Morley

    Hi Enoch,

    I think the simplest thing for you to do is to enable the "Custom LUT Package" from the Packages tab in RV's preferences dialog by clicking both Installed and Load. Then after you restart RV you will see a "Custom LUT" menu with the options "Force View->No Correction On Launch" and "Force Color->No Conversion On Load". Enabling those two options will give you what you are looking for.

    But I want to say one more time that this workflow is usually problematic in other ways. It is very uncommon that you would not linearize quicktime movies for example and certainly rare to have no display correction. You will certainly be missing out on one of RV's greatest strengths which is automatic color management.

    Please let me know if that works for you.

    Thanks,
    Jon

  • 0
    Avatar
    Enoch Davis

    Jon,

    I've turned on the Custom LUT menu, selected "Force View->No Correction On Launch" and "Force Color->No Conversion On Load," and re-started RV. I'm not working with any Quicktimes. But even after saving a session of RV, it keeps reverting to View > sRGB.

    Our files are already put into a linear color space, so RV is doubling the LUT.

  • 0
    Avatar
    Enoch Davis

    Excellent- creating a display profile fixed it, and making it the default is staying saved after closing and launching. :)

    Just to confirm: this method is using the monitor settings to control RV's View settings, correct?

    Thanks!

  • 0
    Avatar
    Jon Morley

    Hi Enoch,

    I am also seeing that behavior. I will look into it. In the meantime you can use display profiles to set your display to no conversion as well. Here is the documentation for display profiles:

    http://tweaksoftware.com/static/documentation/rv/current/html/rv_manual.html#Presentation_Mode_and_Video_Devices_Display_Profiles

    After you set up a display profile you can make it the default on the Video tab of RV's preferences dialog.

    Thanks,
    Jon

  • 0
    Avatar
    Jon Morley

    Hi Enoch,

    Yes. Using the display profile will control the view settings.

    I am glad things are working for you. I will let you know when I have a fix for the Custom LUT Package should you choose to use that approach later.

    Thanks,
    Jon

  • 0
    Avatar
    Jon Morley

    Hi Enoch,

    I think I found a fix for the Custom LUT approach as well. It will now be included in all releases.

    Thanks,
    Jon

  • 0
    Avatar
    Enoch Davis

    Great- thank you!

  • 0
    Avatar
    Jon Morley

    No problem, Enoch!

  • 0
    Avatar
    Nishith Singhai

    Hi,

        My issue is on same lines as Enoch. You've suggested custom LUT packages. Now the "custom LUT packages" is not there in preferences -> packages nor is it present in plugins/Packages folder of rv install. How can i get this package ?

    I am using rv version 3.12.20

     

  • 0
    Avatar
    Jon Morley

    Hi Nish,

    That package was added in the later RV-4 releases. We are now on RV-7. Is there any chance you can upgrade to a more recent version of RV? You will find the package included in the latest release here:

    http://tweaksoftware.com/downloads

    Thanks,
    Jon

请先登录再写评论。