Problem when launching an app from SG

Hi there,

I wrote an app to publish an image sequence and it used to work but since today I have a strange error. When I launch my app through Shotgun (with a right click on a shot for example), the UI appears (no problem with that), the publish is launched but it stop during the process (I don't have any errors, the function just stop...)

When I launch my app from the tank.bat shotgun_run_action command, the UI appears, the publish is launched and everything is right ! It is the same context and the same arguments yet !

I don't understand where the problem could come from... If you can help me, it would be wonderful :)




3 条评论

  • 0
    Manne Öhrström

    Hello Barbara!

    Do you know if you are you using the browser plugin or the java applet to handle the menu generation inside of Shotgun? And if it is the browser plugin, which version are you currently on? We have had some issues in the past where stdout/stdin/stderr buffers would potentially fill up in the browser plugin and therefore cause execution to stop - this sounds like what you are seeing could possibly be related to that.

    One thing to try if you haven't already tried it is to download and install the latest version of the Shotgun browser plugin (here: https://github.com/shotgunsoftware/browser-plugin#installation).

    Let us know how it goes!


  • 0
    Barbara Laigneau

    Hello Manne,

    You were right, my problem came to the Shotgun plugin! The two workstations were I tried my app had each a different problem: one of them used Java and the other had the 0.0.4 version of the ShotgunPlugin

    Thanks a lot for your answer, I would not have been able to find the problem by myself...

  • 0
    Manne Öhrström

    Great! Glad I could help! :)