0

Start RV and disable LUT from command line

Loading a LUT with the command line argument works fine, but I want it to be disabled on startup, so that the Artist can enable the LUT with the shortcut shift-D, when he wants to.

 

I tried this command,which loads the LUT, but the disabling the LUT doesn't work:

"C:\\Program Files\\Shotgun\\RV-7.2.1\\bin\\rv.exe" D:/tst.exr -dlut D:/dlut.cube -eval "setIntProperty(\"#RVDisplayColor.lut.active\", int[] {0}, true);"

4 条评论

  • Avatar
    Jon Morley 正式评论

    Hi Richard,

    The timing of things is such that your eval is executed before the LUT is applied to the display unfortunately. I think you might be better off trying the "Custom LUT Menu Mode" package we include with each release of RV. If you open RV's Preferences and navigate to the Packages tab you will find the package in the list there. You can enable both boxes for installed and loaded and the restart RV. After that you should see a new "Custom LUT" menu with more options over how to control source and display LUT (as well as CDLs if needed). Additionally this menu allows you to set a default display lut but have it disable.

    Furthermore you might be interested to learn more about Display Profiles that can be used to set display LUTs as well. Please read more about Display Profiles here:

    http://tweaksoftware.com/static/documentation/rv/current/html/rv_manual.html#Presentation_Mode_and_Video_Devices_Display_Profiles

    Thanks,
    Jon

  • 0
    Avatar
    Richard Frangenberg

    Hey Jon,

    thanks for your reply. The Display Profiles solution works for me, although I would prefer a completely automated solution (default RV installation with command line parameters).

    I already saw the "Custom LUT Menu Mode" package, but I couldn't find the right settings to disable the LUT:

    I set the display LUT folder and apply the right LUT and use the set as default display LUT. When I use the "Auto load default display LUT on launch", the LUT is loaded and applied. Am I missing an option for disabling the loaded LUT?

  • 0
    Avatar
    Jon Morley

    Hi Richard,

    I am glad the Display Profiles are working for you. Did you set the LUT but disable it and then save that as your profile?

    Thanks,
    Jon

  • 0
    Avatar
    Richard Frangenberg

    Hey Jon,

    I think I misunderstood you. I thought the "Custom LUT Menu Package" already includes an option for disabling the LUT. When I disable it and save it as a Display Profile, it works of course.

    Thank you,

    Richard

请先登录再写评论。