0

Launching Toolkit commands from Mac browsers

Hi,

We've recently had a few problems with our Mac setup with Toolkit.

The setup we have is that we have a single app that can execute a few different scripts, based on the configuration. So, for instance, we can then add a project action that points to an ingestion script, a playlist action that points to a delivery script, etc.

The app is responsible for extracting the context, setting up the environment, and then launch the script itself. Usually it would run the script in a new terminal so the user can see any console output (useful to debug but also to see progress of ingestion scripts, etc.). On Linux, we do that by launching a xterm command. On the Mac, it is done through an osascript which sends a command to the Terminal application to execute the script.

A couple of weeks ago, this last part (the osascript => terminal) stopped working on the macs. We temporarily fixed it by launching the script directly, and not through a terminal, on the macs.

Now, even that stopped working. It looks like the bash environment is not sourced anymore when the action is run, because the environment misses some variables that are setup by the bash init scripts.

It was all working fine before. I suspect some automatic updates applying security fixes.

Anyone else experienced similar issues?

Benoit

 

댓글 1개

  • 0
    Avatar
    Benoit Leveau

    It works fine when launching Firefox/Chrome from a bash terminal, so I created a shell command script that just launch the browser, and the users will use this to launch the app from now on.

    Hopefully it'll be less troublesome with the new version of the shotgun browser plugin planned for later this year....

    Benoit

댓글을 남기려면 로그인하세요.