0

Perforce app install

Hello,

 

I installed the Perforce app on a test project, and I'd like to push the configuration on our project.  seems it's not working when I did it using the project actions menu "push project configuration"

could you please tell me about the right process to follow ?

 

Thank you in advance,

A.

댓글 8개

  • 0
    Avatar
    Alan Dann

    Hi Amina,

    Do you have a configuration already set up on the main project or is this going to be the new full configuration?

    The Push Configuration command only allows you to push configurations within the same project, for example when you have a development sandbox pipeline configuration that you want to push to the main configuration.

    You can use the tank setup_project command to set up a project with the configuration from another project - do this by specifying the full path to the configuration when it asks instead of the default (tk-config-default).  If you've already set up Toolkit for the project but are happy to completely override it with your new config then you can use the --force flag with the setup_project command, e.g. tank setup_project --force.

    Does that help?

    Thanks

    Alan

  • 0
    Avatar
    Alan Dann

    Note, the setup_project command isn't available from the Shotgun menu so you'll have to use the tank command from the command line instead!

  • 0
    Avatar
    Amina Rachdi

    Hello Alan,

     

    Thank you for the quick response.

    I used the command with --force attribute.  however I got an error saying "Looks like the location 'z:\mnt\software\shotgun\odyssey' already contains a configuration "

    is there another command to force chaging the configuration of my project with the perforce config I'm using in the test project ?

     

    Note, I specified the entire path of the perforce test config.

     

    Thank you in advance,

     

    A.

     

  • 0
    Avatar
    Amina Rachdi

    Hi Alan,

     

    I backuped the old config, but I'm afraid I still have the same message.

    note, I made the config folder of my project empty !

     

  • 0
    Avatar
    Alan Dann

    Hi Amina,

    This is a safety check to ensure you don't accidentally overwrite a configuration you need!

    Just delete (or backup) the old configuration directory (z:\mnt\software\shotgun\odyssey) before running the command and it should work fine - sorry, I should have thought to mention that before!

    Thanks

    Alan

  • 0
    Avatar
    Alan Dann

    Hi Amina,

    The directory z:\mnt\software\shotgun\odyssey shouldn't exist before you run setup project so try deleting it completely - does that work?

    Thanks

    Alan

  • 0
    Avatar
    Amina Rachdi

    Hi Alan,

    Just to get back you and confirm that it worked.  thank you for your help & support.

     

    A.

  • 0
    Avatar
    Alan Dann

    Hi Amina,

    That's brilliant and thanks for letting me know.  

    Please shout if you have any more problems ;)

    Alan

댓글을 남기려면 로그인하세요.