Launching Hiero

When I try:

tank launch_hiero

I get:

Error: The action 'launch_hiero' could not be found!

It runs fine from the browser,
If I try it with a task I get the right context but, the same error.
How do we get Hiero to launch from the command line?


  • 0

    Hi Steven,

    Can you try running it with this command:

    tank Project <your_project_name> launch_hiero

    When you invoke the tank command from the command-line, you're using the shell engine. The shell engine gets configured with it's enabled apps using your environment file (which are located in /path/to/toolkit/software/shotgun/<your_project>/config/env). Currently the Hiero Toolkit integration only works in the Project context. So you have to provide that context to the tank command so it knows which environment to load.

    In the default config, you can see in your project.yml environment file, the shell settings have a Hiero launcher:

    apps: {tk-multi-launch3dsmax: '@launch_3dsmax', tk-multi-launchhiero: '@launch_hiero',
    tk-multi-launchmaya: '@launch_maya', tk-multi-launchnuke: '@launch_nuke', tk-shotgun-launchphotoshop: '@launch_photoshop'}
    debug_logging: false
    location: {name: tk-shell, type: app_store, version: v0.3.7}

    Hopefully that answers your question. Let me know if you have any others!

  • 0
    Steven Quinones

    I tried that and I get an error, I also tried giving it the id but no dice.

    Z:\software\shotgun\the_prize>tank Project the_prize launch_hiero
    Welcome to the Shotgun Pipeline Toolkit!
    For documentation, see https://toolkit.shotgunsoftware.com
    You are running a tank command associated with Shotgun Project 'The Prize'.
    Only items associated with this project will be considered.

    ERROR: An error occurred when searching in Shotgun: API read() Project.project doesn't exist: {"path"=>"project", "values"=>[{"type"=>"Project", "id"=>66, "name"=>"The Prize"}], "relation"=>"in"}


    Z:\software\shotgun\the_prize>tank Project 66 launch_hiero

    Welcome to the Shotgun Pipeline Toolkit!
    For documentation, see https://toolkit.shotgunsoftware.com
    - Using configuration 'Primary' and Core v0.14.48
    - Setting the Context to The Prize.
    - Started Shell Engine version v0.3.7
    - Environment:
    - Running command launch_hiero...

    Command: Launch hiero

  • 0

    Hi Steven,

    I think I see what's happening. There's a bug in the project-level tank command implementation that causes that error you see in the first example. However, the second example should work and from the output you pasted, it looks like it did. Did Hiero not launch when you substituted the Project id?

    While the issue exists for the Project-level tank command, if you use the studio-level tank command with the Project name, things should work. You can test that by running:

    Z:\software\shotgun\studio\tank Project the_prize launch_hiero

    We have a ticket to fix this one. And we're also looking to make this all a little easier and less confusing! For example, if you use the project-level tank command, with no arguments, the Project context should be assumed. I've linked this post to the ticket so we will follow up when it's been resolved.

    In the meantime, let me know if you've got it launching with the workarounds or if you're still stuck.

  • 0
    Steven Quinones

    The command with the id confused me too, it looked like it worked but I didn't get an instance of Hiero, I looked in the task manager. But your trick of doing it from the studio level worked! Thanks.

    I'm getting lots of hung hiero proceses while using the exporter and I'm hoping that running from the command line might help alleviate those. I'm also getting a lot of messages:  "HieroQuiteHelper-32.exe has stopped working" the export files seem to be fine though. I haven't looked into that problem yet. Here is the error if it's any help. Thanks for the help.



    Problem signature:
    Problem Event Name: BEX
    Application Name: HieroQuickTimeHelper-32.exe
    Application Version:
    Application Timestamp: 529e3c09
    Fault Module Name: MSVCR100.dll
    Fault Module Version: 10.0.40219.325
    Fault Module Timestamp: 4df2be1e
    Exception Offset: 0008af3e
    Exception Code: c0000417
    Exception Data: 00000000
    OS Version: 6.1.7601.
    Locale ID: 1033
    Additional Information 1: b1a6
    Additional Information 2: b1a6653d97648447022e01a7bd5ac852
    Additional Information 3: a410
    Additional Information 4: a4105df0f34a9abd13c020246ac91cfd


  • 0

    Glad you got it working with the studio-level command.

    We do have some issues when using the browser plugin on Windows with logging enabled that is causing hangs in some of the Toolkit-enabled apps. We're working on a resolution for that. Some more questions:

    1. Are you using the Shotgun browser plugin? Let us know if launching via the shell alleviates some of these issues. If it does, in the meantime you could enable Java instead until we have a fix pushed out.
    2. What version of Hiero (and Nuke) are you running? 
    3. Is your Hiero source media RED files or otherwise extremely large filesizes? The Foundry acknowledged that Hiero and Nuke had some issues with Quicktime generation on Windows for large files where Quicktime would run out of memory during the file generation. Not sure if that's what you're running into, but they said with v8.0v2 this should be resolved.
  • 0

    Issues with the browser plugin causing hangs have been resolved. The new version (v0.0.5) of the browser plugin can be downloaded from Github: https://github.com/shotgunsoftware/browser-plugin

    The discussion regarding Hiero hanging is also continuing in this thread: https://support.shotgunsoftware.com/entries/95444338

Please sign in to leave a comment.