0

Issue with YAML parsing

I am reading chapter 10 in the RV reference manual, which covers creating a simple package.  I am trying to create my own version of the mystuff package.  However, when I try to add the package to RV, I always get this error message:

ERROR: YAML parser failed on PACKAGE file in C:/Users/spearsc/AppData/Roaming/RV/Packages/mystuff-1.0.rvpkg

I wish the error message was more explicit.  I set the console to show on any output, but I did not get any additional information.

Here are the contents of my YAML file:

package: My Stuff
author: Chris Spears
version: 1.0
rv: 7.1.0
requires: ''

modes:
    - file: mystuff
      load: immediate

description:  |
    <p>My Personal RV Customizations</p>

Not sure what I am doing wrong.  The file is called PACKAGE.yml.  The extension does not seem to cause any trouble with an earlier example.

 

3 comments

  • Avatar
    (Michael) Kessler Official comment

    Hi Chris,

    Have you tried not including an extension on your PACKAGE file?  While the PACKAGE file is a yaml format, it shouldn't have the extension.

    You mention, however,

    The extension does not seem to cause any trouble with an earlier example.

    by this do you mean including the .yml on your PACKAGE?

     

    Thanks,

    -Kessler

  • 0
    Avatar
    Spears- Chris

    I did test the contents of my file with YAMLlint (http://www.yamllint.com/).  Apparently, it is valid.

  • 1
    Avatar
    Spears- Chris

    Go figure.  Removing the extension worked.  I guess if you are trying to create a package that consists of more than just a PACKAGE file you need to drop the extension.

Please sign in to leave a comment.