0

RV LUT per show basis

Is there a way in RV to have a LUT setup on a per show basis?

For eg.

Show A - DPX - rec709

Show B - Viperlog - sRGB

 

Also, does anyone know how I can setup the RV preferences on per user basis? As of now we have RV installed on the server and the artists need their own settings (shortcuts, UI preferences etc.).

 

Thanks,

Varun

 

7 条评论

  • 0
    Avatar
    Jon Morley

    Hi Varun,

    I have attached (linked below) a package that has some extra features for automatically loading LUTs named a certain way and stored in a specific location. I would suggest building from this example and changing it to meet your needs. This example works with CDL and 3DL LUTs.

    For your question about setting up user preferences I would take a look at RV's hierarchical preferences documented here:

     12: Hierarchical Preferences

    Please let us know if these do the trick.

    Thanks,

    Jon

  • 0
    Avatar
    Dan Rosen

    Hi Jon. I downloaded this tool and it seems to work well. There is, however, a repeatable bug. If you drag a clip in as a new source then the "Color" and "View" settings of "No Conversion" and "No Correction" will stick. On subsequent drags the "Color" will set back to sRGB. My sys-admin Dan Browne added this line to keep the "Color" setting to "No Conversion".

    rv.commands.setIntProperty(sc+".color.sRGB2linear", [0], False)

  • 0
    Avatar
    Jon Morley

    Hi Dan,

    I am glad it is working now. Is there any chance you would be willing to share the modified package here? I think that would be very helpful.

    Thanks,
    Jon 

  • 0
    Avatar
    Dan Rosen
    I stuck the only line we modified in my previous comment, but after testing further the Color setting is still not sticking to No Conversion.
  • 0
    Avatar
    Jon Morley

    Hi Dan,

    When you say it is not sticking to No Conversion do you mean under the Color menu or the Image menu or both?

    In this package right now setting the options under the menus happens at then end of each source load. In theory it should reinforce the conversion settings you have chosen. Please let me know if you have figured out what seems to be amiss for you.

    Thanks,
    Jon

  • 0
    Avatar
    Dan Rosen

    The issue is specifically with the "Color > No Conversion" not sticking. "View > No Correction" happens to stick appropriately. We (along with other houses, whom I'm helping with this package) prefer to have both of those settings when using log images and a log, 3D LUT applied as the "Display LUT". I found it to be repeatable; the first drag and drop of a log, DPX image the settings will stick correctly, but the second drag and drop'd clip will change "Color" to "sRGB" rather than stick to "No Conversion" as the first one had. I can only get "Color" to stick to "No Conversion" when using your environment variable. The code that I mentioned on my first comment on 5/10 did not wind up working. Give me a call at Evil Eye, which might be easier to go over it.

  • 0
    Avatar
    Jon Morley

    Hi Dan,

    I have updated the Custom Lut Mode package to handle this for RV-4. Please give it a try. It is included in each release as an optional package.

    Thanks,
    Jon

请先登录再写评论。