0

question about matte and matte opacity

Hi seth and alan,

 

one question about the matte option. I tried to save a specific matte setting (2,35 at 100% op) in the RV session but Rv seems to forget the setting.

I was wondering if that is intentional ?

Or can we store that setting somehow or add in the comandline ?

 

All the best Johannes

4 条评论

  • 0
    Avatar
    Don Campbell

    I have been looking for this as well.  Thanks.

  • 0
    Avatar
    Jon Morley

    Hi Guys,

    RV now saves your opacity preference from the last time you ran it. You can't really save the setting in the session right now, though that might be possible in upcoming releases. However you can specify which matte settings you want to use on launch by adding the following to the end of your normal RV command:

    -eval 'use rvui; rvui.setMatteValue(2.35); rvui.setMatteOpacityValue(1.0);'

     

    Thanks,

    Jon

  • 0
    Avatar
    Donald Strubler

    Hi Jon,

    Great help. Does everything follow the same naming convention for ui flags? I have some errant headers indicating a wrong pixel aspect when read from file. I tried

    -eval 'use rvui; rvui.setPixelAspect(1);

    to no success. Any thoughts?

     

    Thanks

  • 0
    Avatar
    Jon Morley

    Hi Donald,

    There is no method in rvui called setPixelAspect. If you want to set the pixel aspect of your source you will want to set the float property value of the #RVLensWarp.pixel.aspectRatio for the sourceGroup. Please see the following documentation:

    RVLensWarp

    Please let me know if that helps.

    Thanks,
    Jon

请先登录再写评论。