0

'-crop' flag from command line (3.8.6)

Hi everyone,

I'm trying to use the RV '-crop' flag from the command line but am having no joy with it. Is this a known issue? Have people experienced the same problem?

rv -crop xmin ymin xmax ymax shotPath.#.dpx

- No crop is applied to the image sequence.

- The image plays back as normal

- I have tested this with, and without, inhouse packages installed so can confirm that it is not a conflict regarding this.

Any information would be hugely appreciated.

 

Thanks,

Eoghan

1 条评论

  • 0
    Avatar
    Alan Trombla

    Hi Eoghan,

    "-crop" is a "per-source" command-line argument.   That is, each source on the command-line can have its own crop values, so to associate the source with the crop they must be enclosed in square brackets ("[ ]").  So your example should work as you expect if you do it like this:

    rv [ -crop xmin ymin xmax ymax shotPath.#.dpx ]

    Here is the complete list of per-source arguments (from "rv -help"):

    Per-source arguments (inside [ and ] restricts to that source only)

    -pa %f                  Per-source pixel aspect ratio
    -ro %d                  Per-source range offset
    -fps %f                 Per-source or global fps
    -ao %f                  Per-source audio offset in seconds
    -so %f                  Per-source stereo relative eye offset
    -volume %f              Per-source or global audio volume (default=1)
    -flut %S                Per-source file LUT
    -llut %S                Per-source look LUT
    -pclut %S               Per-source pre-cache software LUT
    -cmap %S                Per-source channel mapping (channel names, separated by ',')
    -crop %d %d %d %d       Per-source crop (xmin, ymin, xmax, ymax)
    -uncrop %d %d %d %d     Per-source uncrop (width, height, xoffset, yoffset)
    -in %d                  Per-source cut-in frame
    -out %d                 Per-source cut-out frame
    -noMovieAudio           Disable source movie's baked-in audio

    Hope that helps,

    Alan

请先登录再写评论。