0

Which version of glew is used by rv?

I'm writing a RV plug-in in Python to leverage some modern OpenGL features. All OpenGL code is encapsulated in a C++ library and its python wrapper is called. It works partially. But I have to replace the dynamically loaded glew 1.9/2.0 in the C++ library with another gl extension loading library: glad. Otherwise when glewInit is called, it generates a segmentation fault.

I inspect symbol of rv.bin, it seems already statically linked with a glew. But with other information stripped off, I can't tell the exact version.

And if the glew embedded in rv can't get along with the one I need to load some modern OpenGL functions in my library, what should be the best solution. As I said, glad works, but I have concern if it may mess up OpenGL functions needed by rv.

0 条评论

请先登录再写评论。