2

Add DNxHR codec support to RV

Hello,

Is there a way to add support of a codec to the RV Player? We are using RV 6.2.6.

My team would like to view quicktime videos with the DNxHR codec that AVID uses (http://avid.force.com/pkb/articles/en_US/download/Avid-QuickTime-Codecs-LE).

Right now if we try to view these mov files in RV we get this error:

ERROR: MovieFFMpeg: Unsupported codec_id '0' in OUR_PATH_NAME_HERE 
ERROR: Unable to find a video track. (0)

Simply downloading the codec onto my machine and trying to play the video in RV afterwards didn't work. Is there a way for us to add this codec to the codecs that RV supports/recognizes?

Thanks,

Sylvia

3 条评论

  • Avatar
    (Michael) Kessler 正式评论

    Hi Sylvia,

    Unfortunately, the codec needs to be compiled into our io library for it to work with RV. While we have an internal desire to add this codec, would you mind making the feature request over at our feature request forum so we can get some voting on it?

    https://support.shotgunsoftware.com/hc/en-us/community/topics/200682468-RV-Feature-Requests

     

    Thanks,

    -Kessler

  • 0
    Avatar
    Sylvia Kosowski

    Hi Michael,

    As I was searching for information on this topic, I came across this post: 

    https://groups.google.com/a/shotgunsoftware.com/forum/#!topic/shotgun-dev/vERfuU092Sc

    Which mentions rebuilding the ffmpeg plugin for RV to handle additional codecs. Will this method not work for this codec?

    I'll create a feature request as well. Is there a time window that you are looking at in which to add this feature?

    Thanks!

  • 0
    Avatar
    (Michael) Kessler

    DNxHD support was (at the time of that post) compiled into RV, but disabled due to licensing.  The recompilation is just the last mile of the inner workings that disable the support.  By modifying that file and recompiling it, (at the time) you were specifying that you had a license and that you could use the support that was compiled in.

    As of today, DNxHD is licensed through RV's base codec licenses, so it is now enabled by default.  DNxHR, however, requires a newer component for us to compile support in and therefore isn't already compiled in. 

    Unfortunately, in this case, it is not simply a matter of enabling the codec, though there has already been an investigation into what compiling in the newer component would look like.

     

    Thanks for making the feature request!

请先登录再写评论。