0

RV, Set Default Framerate Preference via command line

Hi,

Im a huge RV fan, great job everyone!

Just had a question about setting RV preferences via the command line preferably, or even by the api. 

I cant seem to find out how to change the default fps that is within the RV preferences dialog by code/command line. Im aware of how to set fps on sources via commandline, its just that Id like to set the Applications Default FPS.


Thanks for any ideas!

3 条评论

  • 0
    Avatar
    (Michael) Kessler

    Hi Eric,

    Nice to see you on here!

    I am afraid to say there is no command line way to modify that particular setting. You can share that setting across a studio with hierarchical prefs as described here:

    http://tweaksoftware.com/static/documentation/rv/current/html/rv_reference.html#Chapter_15_Hierarchical_Preferences

    The easiest way to make a preference file for the hierarchical prefs is to set your desired prefs, then close RV and remove everything from the preference file you don't want and then add that to the associated path.

    Will that help/work for you; if you'd prefer a command-line argument, it looks like it mostly needs to be hooked up and we can open a feature request for that.

  • 0
    Avatar
    Eric Bates

    Hey Michael,

    Thanks for the quick reply! Nice to see you too :)

    I was looking for a way to set the default frame rate to work around another issue that relates to Shotgun Review, but maybe its better to address the root of the problem. So I'm sure you're aware, the Submit Tool in Shotgun Review will generate a mov of your source footage and audio (including any audio offsets). Although apparently the audio sync seems to change in the mov generated from this process when the default frame rate of RV is different than the footage source fps. My guess is that the conversion system is basing the offsets on RV's default fps rather than the source footage's fps. This has popped up with working across multiple shows with varying frame rates (24, 30).

    Is this something that you've come across before?

     

  • 0
    Avatar
    (Michael) Kessler

    Eric,

    I don't think I've come across this one before.  Are you using the per-source argument for fps, the global fps, or otherwise?

    I just tried reproducing this with no luck, If there's any way you could share a sample of the command-line arguments that you use to reproduce this I can try to track down where the root problem is.

请先登录再写评论。