0

Exception raised while toggling single channel display using the factory OCIO package.

 Hi,

This happens with RV 7.0.1 and RV 6.2.7 and using the factory OCIO package that ships with the application: whenever I toggle single channel display using the r, g or b hotkeys, a Python exception get raised:

INFO: D:/tmp/RV/Digital_LAD_2048x1556_Model - Reference.exr
INFO: using OCIOFile node for sourceGroup000000_source RVLinearizePipelineGroup
INFO: using OCIO for display
ERROR: event = key-down--r
ERROR: function = __lambda930 (void; Event ignored)
ERROR: Exception Value: exception: "invalid property name @RVDisplayColor.color.channelFlood" 

My understanding is that RV is attempting to set a property that doesn't exist since the RVDisplayColor node isn't here anymore because being replaced by the OCIODisplay one.

I would like to hear if there are any workarounds for that, I still do want that channel toggling capability though.

Cheers,

Thomas

8 条评论

  • Avatar
    Jon Morley 正式评论

    Hi Thomas,

    In RV's preferences on the Packages tab you will find a "Color Channel Selection" package. Make sure that is both installed and loaded and restart RV. You should then be able to use those features again with OCIO.

    Thanks,
    Jon

  • 0
    Avatar
    Thomas Mansencal

    Thanks Jon!

    Is there a file in the RV_SUPPORT_PATH location where I can define that this package should auto-loaded? I suppose the rvload2 is the place for that but the syntax is not really clear.

    Cheers,

    Thomas

  • 0
    Avatar
    Jon Morley

    Hi Thomas,

    We don't expect/want users to hand edit the rvload2 file. I think what you want to check out are the rvpkg tool and possibly hierarchical preferences:

    http://tweaksoftware.com/static/documentation/rv/current/html/rv_reference.html#Chapter_9_Package_System_rvpkg_Command_Line_Tool

    http://tweaksoftware.com/static/documentation/rv/current/html/rv_reference.html#Chapter_15_Hierarchical_Preferences

    Thanks,
    Jon

  • 0
    Avatar
    Thomas Mansencal

    Thanks I'll look into that, the RV_PREFS_OVERRIDE_PATH seems to be promising.

  • 0
    Avatar
    Thomas Mansencal

    Hi Jon,

    No luck with either the RV_PREFS_OVERRIDE_PATH or RV_PREFS_CLOBBER_PATH variables on RV 7.0.1 and RV 6.2.7, the variable is properly defined and I can see it in RV environment, the setup is as follows:

    RV_PREFS_CLOBBER_PATH=D:\Tools\RV\RV.ini

    RV.ini
    [ModeManager]
    doNotLoadPackages=$APPLICATION_DIR/plugins/Packages/ocio_source_setup-2.1.rvpkg
    optionalPackages=$APPLICATION_DIR/plugins/Packages/channel_select-1.1.rvpkg

    I deleted the matching section in my user RV.ini file too.

    I hope I didn't miss something obvious. I can also create a proper support ticket if you want.

    Cheers,

    Thomas

  • 0
    Avatar
    Jon Morley

    Please go ahead an make a support ticket. Please include a link to this thread for context.

    Thanks,
    Jon

  • 0
    Avatar
    Thomas Mansencal

    I fixed that with the support, for anyone having a similar issue, the environment variable must actually be set to the directory containing the .ini file, for example:

    RV_PREFS_CLOBBER_PATH=D:\Tools\RV\Preferences

    instead of :

    RV_PREFS_CLOBBER_PATH=D:\Tools\RV\Preferences\RV.ini

    Cheers,
     
    Thomas
  • 0
    Avatar
    Jon Morley

    Awesome catch!

请先登录再写评论。