如何在协作环境中审核

Shotgun 生态系统提供了多种审核媒体的方法。虽然 RV 在生产环境中有许多应用,但本教程重点介绍如何在协作环境(如审片室或会议室)中审核媒体。

审核首先从内容开始,RV 使用本地内容,但 RV 也支持来自 Web 的流内容。本教程假定您有演示项目“Hyperspace Madness”的本地媒体;您也可以使用自己的项目和版本学习本教程。

注意:要使用示例媒体学习,您可以在此下载示例“Hyperspace Madness”影片和图像序列

设置本地媒体

RV 是一款高性能帧序列和影片播放应用程序。因此,RV 需要影片和帧位于磁盘上才能播放。当磁盘上的影片和帧丢失时,RV 还可以播放您的 Shotgun 站点上托管的媒体(上传的影片)。RV 的 Shotgun 集成依靠两个字段来了解您的本地内容位于何处:对于 QuickTime 影片为 sg_path_to_movie,对于帧序列为 sg_path_to_frames

准备要审核的内容

针对项目“Hyperspace Madness”,我们正在努力构建一个协作审核环境,并要有时间意识。提前准备所需内容可以很好地确保审核期间的工作效率,并尽量减少浪费时间。在 Shotgun 中,我们使用播放列表来管理“Hyperspace Madness”媒体(版本)列表,我们可以一起审核这些媒体。这些播放列表属于项目“Hyperspace Madness”的一部分,其中包含版本、顺序以及用于描述播放列表的字段。

信息:有关如何在 Shotgun 中创建媒体的详细信息,请参见媒体应用和播放列表手册中的“上传媒体”

我们首先浏览到“Hyperspace Madness”项目的播放列表视图。 

在本练习中,我们将从头创建自己的播放列表。单击“+ 播放列表”(+ Playlist)并填写以下信息:

  • 播放列表名称(Playlist Name):Review Tutorial Playlist
  • 说明(Description):Playlist for the Review In Context Tutorial

我们的新播放列表将出现在媒体应用播放列表视图中的“最近项”(Recent)和“所有播放列表”(All Playlists)下。

注意:由于我们在“Hyperspace Madness”项目中,因此我们的播放列表将自动链接到“Hyperspace Madness”。如果您在项目之外在媒体应用中创建播放列表,当您创建时,系统将提示您将播放列表链接到一个项目。

现在我们有了一个播放列表,接下来需要将媒体(版本)添加到播放列表。可以通过多种方式将媒体链接到播放列表。浏览媒体时,我们搜索要链接到播放列表的第一个版本:HSM_SATL_0030_ANIM。找到该版本后,单击“播放列表”(PLAYLISTS)选项卡,然后将 HSM_SATL_0030_ANIM 拖动到播放列表中。

也可以在查看版本时将其添加到播放列表。在样片环节中,想要将正在审核的版本添加到另一个播放列表时(例如“总监”审核),上述功能很方便。为了将第二个版本添加到播放列表,我们导航到媒体应用 >“浏览”(BROWSE)选项卡。在过滤框旁的搜索字段中键入 HSM_SATL_0020,然后按 Enter 键。然后选择 HSM_SATL_0020 并单击播放图标。在 Web 播放器中播放版本时,即可在详细信息窗格中找到“播放列表”(Playlists)字段,然后在该字段中键入我们的播放列表:“Review Tutorial Playlist”。现在,已成功链接第二个版本。

 

开始审核

创建播放列表后,就可以开始审核了。打开之前导航到的媒体应用 >“播放列表”(PLAYLISTS)选项卡,导航到“播放列表”(Playlist)。选择“Review Tutorial Playlist”,单击“播放列表动作”(Playlist Actions)下拉菜单(右上角),然后选择“在 RV 中播放”(Play in RV)。如果已正确配置所有设置,我们将在时间线中看到 RV 加载了我们的两个版本。

注意:如果这是您很久以来第一次登录到 RV,启动 RV 时,系统可能会提示您输入 Shotgun 登录凭据。输入凭据后,会转至您已启动的播放列表。

 

疑难解答提示:RV 启动后应显示播放列表;如果未显示,请参见此文档,了解如何为系统设置协议处理程序

如何使用 RV 进行审核

现在已将版本加载到 RV 中,让我们了解一下需要在 RV 中执行的一些常见操作。

时间线管理

首先,通过按“T”热键来切换“提示时间线”。

时间线

现在,我们可以看到时间线,接下来使用空格键开始播放项目“Hyperspace Madness”中的 HSM_SATL_0020。空格键可用于在播放和停止 [暂停] 之间进行切换;我们按空格键开始播放。此时,RV 将按顺序播放时间线中的所有版本。一个版本播放完毕时,将播放下一个版本,然后继续循环整个时间线。

 

虽然最好能审核整个时间线,但分段播放以便在审核过程中重复一个版本或某个版本的一部分也非常实用。当我们在样片环节中与主管一起审核特定的一个或一组镜头时,这项功能就会派上用场。通过使用 fn+向上 ↑/向下 ↓ 箭头键 (page-up/page-down),可以方便地将时间线播放区域限定到当前版本。按 fn+↑ 向上箭头时,当前版本将重复,不显示时间线中的其他版本。如果继续按 fn+↑ 向上箭头,我们将逐个浏览时间线中的每个版本。同样,按 fn+↓ 向下箭头时,您将转到时间线中的每个先前版本。

现在,我们已经了解如何限定版本。接下来,按反斜杠 [\] 键将播放区域重置为整个时间线。

 

在未设置播放区域的情况下,我们也可以前进到特定版本的起始位置。播放列表较长时,此功能特别实用。选择底部托盘中的第二个图标;这会将时间线前进到第二个视频片段但不修改播放区域。同样,我们可以使用 fn+向左 ←/向右 → 箭头(home/end 键)转到视频片段的开始帧/结束帧。

 

提示:拖动某个已限定的版本时,可通过在时间线的右键单击菜单中启用“配置 > Scrub Stops at In/Out”(Configure > Scrub Stops at In/Out)来防止意外拖动到其他版本。
Scrub stops at in/out

现在,我们已经能够在审核期间限定版本,同时从一个版本前进到另一个版本。接下来,主管要求我们关注一个特定剪辑镜头并限定播放该区域。我们可以通过设置标记来执行此操作。要设置标记,按下“m”热键表示起点,再次按下“m”热键表示终点。然后,使用 fn+↑ 向上箭头 (page-up) 同时播放两个版本剪辑镜头的限定部分。我们可以在一次审核中设置任意数量的标记,然后通过导航到“编辑”(Edit)菜单 >“Clear All Marks”来清除这些标记,并使用反斜杠键 [\] 来重置我们的区域。

 

版本比较

Shotgun 和 RV 为依赖于协同迭代审核的行业提供了解决方案。迭代审核关键的一点是能够将当前的工作与以前的工作进行比较。在 RV 中将一个版本与相关版本进行比较很方便。在 Shotgun 审看中,右侧面板包含两个选项卡:“注释”(Notes)和“版本”(Versions)。单击“版本”(Versions)选项卡可显示相关版本。此面板将根据当前播放的版本进行更新。在查看 HSM_SATL_0020_ANIM 时,我们选择 HSM_SATL_0020_TD 版本,右键单击并选择“与当前项比较”(Compare with Current)菜单项。默认情况下,两个版本会放在一个网格中,以便进行比较。

完成版本比较后,选择屏幕左上角的左侧“返回”(back)按钮。此时将返回到播放列表时间线。

 

除了用于比较的网格视图外,还可以将它们竖直放置。与以前的动画进行比较时,或者仔细检查样片中的照明变化时,上述做法非常有用。从“SG Review”菜单中,导航到首选项,然后将“Default Compare Mode”更改为“Stack with Wipes”。重复上述步骤对版本进行比较;这次,我们不会看到两个彼此相邻的版本。将鼠标移动到图像的边缘,靠近边框时将出现擦除工具控制柄。向内拖动边缘以开始显示底部图像。

同样,完成版本比较之后,单击左上角的“返回”(back)按钮以返回播放列表时间线。

 

视图调整

RV 具有一套功能强大的图像工具,可用于分析和调试我们需要在项目中利用的图像中的技术和艺术缺陷。完成一个镜头后,即可使用这些工具检查该镜头,以便进行“技术修复”。

对样片进行“技术修复”时,主管让我们对图像进行加亮处理,以查看是否有瑕疵。为此,我们使用 e 键调整当前版本的曝光效果,然后在查看器中自左向右拖动。还可以设置特定值来更改曝光:按 e,键入 2,然后按 Enter 键。

 

现在,我们需要提高 HSM_SATL_0020_TD 的对比度。按 k 键并自左向右拖动可提高对比度。

 

使用 shift+insert 组合键或使用“颜色 > 重置所有颜色”(Color > Reset All Color)选项可重置所有这些更改。

重置所有颜色

最后,我们分别看看每个颜色通道。按 rgb 键可切换视图以分别单独显示“红色”、“绿色”或“蓝色”通道。我们尝试每个键,想要将视图重置为全色时,按 c 键。

 

注释

在审核后,务必确保美工人员和主管了解需要更改哪些内容。对于少量的审核,以及当主管在美工人员处进行审核时,我们可以使用 RV 中的“注释”(Notes)面板。在相关版本所在的右侧面板中,单击顶部的“注释”(Notes)选项卡。

“注释”(Notes)面板

“注释”(Notes)面板和“版本”(Versions)面板一样,会与当前镜头同步更新。之前的注释显示在下面,我们写下的新注释显示在上面。我们使用 @ 符号,以便“抄送”美工人员 Johnny,提醒他查看我们的反馈。提交注释时,单击右下角的复选标记,他们将通过 Shotgun 收件箱获得通知(根据用户的通知首选项,还可以通过电子邮件获得通知)。

提示:在 @ 符号后面键入用户姓名的几个字符之后,您将看到一个有效用户的列表供您选择。

 

对于大量审核,建议不主导审核的人员使用审核注释应用

实用设置及其位置

RV、Shotgun 审看以及 RV 中的一些工具都有一些可以改变 RV 行为的首选项。与设置擦除模式的方式类似,“SG Review > 首选项”(SG Review > Preferences)菜单包含一些有用的首选项,如默认媒体类型、自动播放以及一些显示设置。

SG 首选项菜单

RV 本身在“RV > 首选项”(RV > Preferences)面板下方有一组非常重要的首选项。缓存设置、音频和视频首选项以及插件都可以在这里进行管理。最后,某些工具有自己的首选项。时间线(托盘上方的时间视图)是一种提供实用设置的工具。

RV 首选项

延伸阅读

如果您想更加熟练地掌握如何使用 RV 来运行审核,强烈建议您首先熟悉 RV 内更为全面的工具。本教程只是简要介绍。以下是值得查阅和收藏的其他一些手册:

关注