SGTK after lauchning RV from Shotgun


i have the problem, that RV is only using "Toolkit v0.18.18rv" after i launched it from the Shotgun Actions Menu. I need to access some data from projects which have a higher core version, which gives me the following error:

You are running Toolkit v0.18.18rv located in 'C:\Users\Node_013\AppData\Roaming\Shotgun\vast\site.rv_review\cfg\install\core\python'. The configuration you are trying to use needs core version v0.18.167 or higher.

I tried to import "sgtk" from the projects core directory (/path/to/project/sgtk/install/core/python) which works without errors.
But if i run:


it uses the module located at 'C:\Users\Node_013\AppData\Roaming\Shotgun\vast\site.rv_review\cfg' which is also written to the enviroment variable "TANK_CURRENT_PC".
I tried to change "TANK_CURRENT_PC" for the time i need the other sgtk module, but it doesn't work either.
I also tried to override 'sgtk' module, but it was not successful.

Is there a solution for that problem?


댓글 0개

댓글을 남기려면 로그인하세요.