0

Launching RV with Studio Preference File

We want to launch RV with a studio preference file, we're doing that by using -prefPath pointing to our "TweakSoftware\RV.ini" file.


When doing that, we notice it prevents the user from saving his own additional preferences. Also they will have to authenticate to Shotgun every time they log in.

댓글 7개

  • Avatar
    (Michael) Kessler 공식 댓글

    Hi Michael,

    RV actually has a notion of concatenating files in an ordered fashion, so that a studio can set defaults and/or overrides.  These are specified by setting two environment variables.

    If you want to allow a user to set a preference and then no longer take the preference from the studio preference (basically a default for new users) you can use: RV_PREFS_OVERRIDE_PATH

    Otherwise, if you want a preference to be used instead of whatever the user specifies, use: RV_PREFS_CLOBBER_PATH

     

     

    Check out the reference documentation on Hierarchical Preferences here:
    http://www.tweaksoftware.com/static/documentation/rv/current/html/rv_reference.html#Chapter_15_Hierarchical_Preferences 

  • 0
    Avatar
    Michael Wright

    Thanks for the info Michael.

    So I can set RV_PREFS_OVERRIDE_PATH to override default values, and RV_PREFS_CLOBBER_PATH to stomp over all values. One question though, if these are environment variables for how to use preference files then what is the intended use of the -prefPath flag?

  • 0
    Avatar
    (Michael) Kessler

    Michael,

    The flag might be useful if you wish to have your user settings source/write to a nonstandard location.

    For instance, if you are debugging a user profile, you can use the flag to point at another user's prefs path.  Or on a studio level, if you are trying to save prefs to a location that is not in the user's home directory (such as mount point that has different characteristics).

  • 0
    Avatar
    Michael Wright

    That makes sense. In any case it looks like it should not be used to set preferences for multiple users, but instead to use the RV_PREFS_OVERRIDE_PATH/RV_PREFS_CLOBBER_PATH environment variables.

  • 0
    Avatar
    Michael Wright

    I seem to be having trouble getting these preference files to apply.

    When I go into Help->Shot Environment I can clearly see my RV_PREFS_OVERRIDE_PATH/RV_PREFS_CLOBBER_PATH set to their own files.

    I've tried experimenting with just font size for now. Both my file in RV_PREFS_OVERRIDE_PATH and RV_PREFS_CLOBBER_PATH have the values: 

    fontSize1=@Variant(\0\0\0\x87\x41p\0\0)
    fontSize2=@Variant(\0\0\0\x87\x41\0\0\0)

    This should change the font size to 15. However it doesn't. Whether or not my actual preference file has these set doesn't seem to matter. The files don't actually seem to be getting applied to my RV session.

  • 0
    Avatar
    (Michael) Kessler

    Hi Michael,

    Is the CLOBBER path set to the file or the directory where the RV.ini file exists?

    Try setting the paths to the directory where the file exists rather than the file itself.

  • 0
    Avatar
    Michael Wright

    That seemed to work. I'd tried pointing to "my_directory/TweakSoftware/RV.ini" and "my_directory" before, which hadn't worked, but setting the value to "my_directory/TweakSoftware" had the files get applied. 

    Thanks so much! This should be resolved now.

댓글을 남기려면 로그인하세요.