0

-sRGB cmd line option

I'm attempting to load a series of sources, and would like this option disabled.

It appears this is not a boolean option.

 

rv.exe 

opens a session, without sRGB enabled.

 

rv.exe [ /source/my_img_sequence.0001.tif 1-2 ]

opens the session, loads the source, but even without specifying -sRGB in the command line, the sRGB was toggled ON.  how do i disable sRGB in this case?

 

THanks!

댓글 8개

  • 0
    Avatar
    Alan Trombla

    Hi Matt,

    To confirm, we're talking about sRGB as an (output) display transform (the option you see in the "View" menu), right ?

    The reason sRGB is not on if you start rv with no media is that rv attempts to produce a suitable display transform for the media you choose.  Assuming the media is properly linearized on input, sRGB is usually the best choice (if you're displaying on a computer monitor).  What color space is your tif file in ?  After you load it, what linearizing transfer is set in the "Color" menu.

    RV does not have a "no display tranform" option (I'll add that to the list).  But you can 'trick' it with a linear transform:

    rv.exe [ /source/my_img_sequence.0001.tif 1-2 ] -gamma 1.00001

    Hope that helps,

    Alan

  • 0
    Avatar
    Matt Tucker

    yep.

    -gamma 1 = fail

    -gamma 1.00001 = works

     

    I def think a -sRGB 0 would be great.  ;)

    Thanks for your help

  • 0
    Avatar
    Troy Moore

     

    Any update on having the ability to turn off the display conversions?  Would like to use -dlut lut -nodisplayTransform

  • 0
    Avatar
    Miklos Kozary

    +1

  • 0
    Avatar
    Ned Wilson

    Along these lines, if I load a DPX sequence, RV is insisting on doing a conversion from Cineon to Linear. Since my DPX frames are not in a Cineon color space, I would love to disable this. Please advise.

  • 0
    Avatar
    Alan Trombla

    Hi Ned,

    What color space _are_ your DPX files in ?

    Alan

  • 0
    Avatar
    Ned Wilson

    Hello Alan,

    They are in Alexa LogC.

    We have a custom 3DL that we use to view these files, so I would like to direct RV, on the command line, to only apply the display LUT. Current, I'm using -dlut /path/to/some/file.3dl -gamma 1.00001. The -gamma is a nice work around to disable the sRGB conversion.

    Thanks!

    -n

  • 0
    Avatar
    Jon Morley

    Hi Ned,

    RV uses the metadata in the files it reads along with some additional heuristics we have built up from deficiencies in popular image formats to determine the best linear transformation to apply to each source you load. If the DPX files you are loading are not getting loaded in the correct space there may be bad or missing metadata. Please share with us the output you get from running:

    rvls -x <SAMPLE_FILE.DPX>

    Where SAMPLE_FILE.DPX is one of the dpx files you are working with that is incorrectly loading. You will find rvls alongside rv in your installation.

    If you know that you want to treat all DPX files that way then you can specify the following environment variable to get what you are after:

    RV_OVERRIDE_TRANSFER_DPX = "ALEXA LogC"

    However it seems like at this point you might want to write your own custom source_setup since you are overriding the behavior of both source conversion and display correction. Have you tried using the "Custom LUT Menu Mode" package? If you are using RV-4 it is included, but disabled. To try it out you only need to open RV's preferences, click the Packages tab, and then check the installed and loaded boxes next to the package in the list. Then the next time you start up RV you should see a new "Custom Color" menu with things like "Force No->Correction for View". As well as ways to load a new default display lut (like your 3DL) and have it automatically applied each launch thereafter.

    Please share with me the rvls output and then I can better tell you what is going on.

    Thanks,
    Jon

댓글을 남기려면 로그인하세요.