0

Fedora Core 12 RV Crashing and PulseAudio

Hi,

 

How are people finding Pulse Audio with RV?

Suggested work around or library needed to get this combination working...

 

Thanks for reading

댓글 5개

  • 0
    Avatar
    Jim Hourihan

    Hi David, RV should work with pulse audio via its ALSA modules. You can try either the "safe" ALSA module (which is "safe" for pulse audio) or the default ALSA module if you don't use the direct hardware audio devices. The best audio device to use is "default" or if you have "dmix" on your system that might work. By default on distros that use pulse, the non-hardware  alsa drivers will be shunted to the pulse server. Some systems (FC8) had some issues with the setup of pulse audio which could cause problems. 

    Can you tell us which distro you're using and which version of RV? 

     

        -Jim

  • 0
    Avatar
    David Ward

    Thanks for the reply Jim.

     

    I guess the real issue is I can not select an audio device/output.

     

    From the beginning...

    Fedora 12 w/ KDE [kdebase-4.3.4-1.fc12.x86_64]

    uname -a
    Linux om012602.drd.int 2.6.31.12-174.2.3.fc12.x86_64 #1 SMP Mon Jan 18 19:52:07 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux


    david.ward@om012602 ~ $
    rpm -qa "*alsa*"
    alsa-lib-1.0.22-1.fc12.x86_64
    alsa-utils-1.0.21-2.fc12.x86_64
    alsa-oss-libs-1.0.17-4.fc12.x86_64
    alsa-plugins-pulseaudio-1.0.21-2.fc12.x86_64
    alsa-oss-1.0.17-4.fc12.x86_64

    david.ward@om012602 ~ $
    rpm -qa "*pulse*"
    pulseaudio-libs-0.9.21-2.fc12.x86_64
    pulseaudio-module-bluetooth-0.9.21-2.fc12.x86_64
    pulseaudio-libs-glib2-0.9.21-2.fc12.x86_64
    pulseaudio-0.9.21-2.fc12.x86_64
    alsa-plugins-pulseaudio-1.0.21-2.fc12.x86_64
    pulseaudio-utils-0.9.21-2.fc12.x86_64
    kde-settings-pulseaudio-4.3-15.2.noarch
    pulseaudio-module-x11-0.9.21-2.fc12.x86_64

    david.ward@om012602 ~ $
    cat /proc/driver/nvidia/version
    NVRM version: NVIDIA UNIX x86_64 Kernel Module  190.53  Wed Dec  9 15:29:46 PST 2009
    GCC version:  gcc version 4.4.2 20091222 (Red Hat 4.4.2-20) (GCC)

    Version 3.6.9, built on Jul 13 2009 at 09:33:30.  (L)

    And

    Version 3.8.4, built on Dec 16 2009 at 15:46:57 (64bit). (L)

     

     

    Now the issue is...

    1. If i launch RV with no args, and press play, it says something is using the audio device and to click on the "Turn Off Audio"

    From there, in Preferences > Audio it says-

    Output Module: Audio Disabled

    Output Device: <empty>

     

    2. Launching with rv --noaudio removes the error and allows playing without an error, but I still have the same as above under Preferences > Audio

     

    /dev/dsp is missing.

    So I ran:

    sudo modprobe snd-pcm-oss

    And chmod 666 /dev/dsp

     

    But makes no difference with RV.

     

    So it seems a much more rudimentary issue than PulseAudio perhaps.

     

    Any suggestions are very welcome and appreciated.

    Thanks for reading.

     

     

     

  • 0
    Avatar
    Jim Hourihan

    It looks like the original FC12 distro has some mismatched RPMs. Specifically libsndfile and pulseaudio. If you use the most up-to-date libsndfile with the original pulseaudio it will cause pulse to crash on the client side (RV). Its possible to make this stable by using an older libsndfile. 

     

    It looks like there are some new upgrades to FC12 that might fix this problem. We'll have more specific info soon.

     

       -Jim

  • 0
    Avatar
    Jim Hourihan

    More info from Johan  van den Dorpe:

     

    Just wanted to let you know we have this working with pulseaudio on f12 now, after we updated the distro. Here's the notes from the build team:

    We're now using the 2.6.32 kernel (not sure Fedora's put this in updates 
    yet. I got it from koji). Then did this on the image to upgrade all 
    the pulseaudio/alsa stuff:

    yum install pavucontrol pavumeter paman padevchooser paprefs alsa- 
    plugins-pulseaudio gstreamer-plugins-pulse pulseaudio pulseaudio-core- 
    libs pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 
    pulseaudio-libs-zeroconf pulseaudio-module-gconf pulseaudio-module-x11 
    pulseaudio-module-zeroconf pulseaudio-utils xine-lib-pulseaudio xmms- 
    pulse

  • 0
    Avatar
    David Ward

    Thanks so much Jim. Appreciate the hard work on this!

댓글을 남기려면 로그인하세요.