브라우저에서 데스크톱 통합

sg_websocket_banner.png

Shotgun 웹 응용프로그램에는 올바르게 실행하기 위해 데스크톱과의 통합이 필요한 두 가지 기능이 있습니다.  첫 번째 기능인 로컬 파일 링크 기능은 Shotgun이 파일 시스템의 파일 또는 디렉토리 경로를 저장한 다음 한 번의 클릭으로 해당 경로를 여는 기능입니다.  두 번째 기능인 툴킷 통합은 Shotgun에서 Maya 및 Nuke와 같은 앱을 시작할 수 있도록 하는 기능입니다.  보안상의 이유로 브라우저는 웹 사이트에서 이러한 앱이 기본적으로 작동하도록 하는 충분한 액세스 권한을 허용하지 않습니다.  이러한 앱이 작동하게 하려면 다음 통합 경로 중 하나를 활성화해야 합니다.

사용 중단

Java 애플릿과 Shotgun 브라우저 플러그인은 모두 NPAPI 기술을 기반으로 합니다. Google은 2015년 9월 Chrome에서 NPAPI에 대한 지원을 중단했습니다.  Firefox는 2016년 말에 지원을 중단할 예정입니다. NPAPI 기반 플러그인이 더 이상 지원되지 않으므로 모든 사용자는 SG 데스크톱을 사용하는 것이 좋습니다. 현재 SG 데스크톱은 Chrome에서 데스크톱 통합을 지원하는 유일한 경로입니다.

Websocket 서버

지원되는 브라우저: Chrome, Firefox, Safari(2017년까지)
지원되는 Shotgun 버전: 6.1.6+

번들로 제공된 웹 소켓 서버가 있는 SG 데스크톱은 현재 모든 사용자에게 지원되는 유일한 통합 방법입니다.

일반적으로 Java 및 NPAPI 플러그인에 대해 계속되는 보안 문제로 인해 이러한 기술을 기반으로 한 플러그인을 점차 지양하고 있는 추세입니다. Google은 이미 이러한 기술을 기반으로 한 플러그인에 대한 지원을 중단했으며 Firefox도 지원을 중단할 계획입니다. Microsoft의 새 Edge 브라우저는 기본적으로 이러한 기술을 지원하지 않습니다.

플러그인이 필요하지 않은 로컬 파일 링크 및 툴킷 통합을 제공하는 대체 방법을 개발했습니다. 최신 설치 프로그램은 컴퓨터에서 실행되는 작은 서버를 설치하고 Shotgun 웹 사이트에서 websocket 커넥션을 수락하도록 간단히 구성됩니다.  websocket 서버는 브라우저 외부에서 Java 및 브라우저 플러그인이 실행되는 동일한 명령을 실행합니다.  이와 같이 로컬로 설치된 응용프로그램에서 실제 시스템 액세스를 수행하는 방식은 이제 이러한 유형의 기능에 대한 Google의 권장 방식입니다. 

websocket 서버는 Shotgun 데스크톱 응용프로그램과 함께 번들로 제공됩니다. 최신 버전은 여기에서 다운로드하십시오 .  Firefox의 경우 websocket 서버와 통신하려면 인증서를 수동으로 설치해야 합니다. Firefox에서 Shotgun의 툴킷 메뉴 오류가 발생하는 경우 이 작업을 가장 먼저 수행하여 해결합니다.

참고: 이전에는 Shotgun 데스크톱과 별도로 websocket 서버를 실행할 수 있었습니다. 독립 실행형 서버는 더 이상 지원되지 않습니다.

브라우저 플러그인(사용되지 않음)

지원되는 브라우저: Safari, Firefox(2016년까지)

Shotgun 브라우저 플러그인은 기본적으로 호스팅된 Shotgun 사이트에서만 자체적으로 사용할 수 있는 컴파일된 플러그인(NPAPI 기술 기반)입니다. 이 작은 플러그인은 위의 두 기능에 필요한 특정 기능을 대상으로 합니다.  추가 구성이 필요하지만 로컬로 설치된 Shotgun 사이트에서 플러그인을 사용할 수 있습니다.  플러그인 설치 방법 및 설치 문제 해결에 대한 자세한 정보는 다음 링크를 참조하십시오. https://github.com/shotgunsoftware/browser-plugin. 보안상의 문제와 브라우저가 NPAPI 기반 플러그인에 대한 지원을 중단함에 따라 브라우저 플러그인의 개발이 중단되었지만 지원은 계속됩니다.

참고: Chrome의 현재 릴리즈에서는 플러그인이 지원되지 않습니다. Safari와 Firefox의 플러그인에 대한 지원은 기본적으로 해제되어 있으며 Mozilla와 Apple도 머지않아 지원을 완전히 중단할 것이라고 밝혔습니다. Safari에서 플러그인을 활성화하는 방법에 대한 지침은 https://support.apple.com/ko-kr/HT202819를 참조하십시오. Firefox에서 플러그인을 활성화하는 방법에 대한 지침을 보려면 https://support.mozilla.org/ko/kb/why-do-i-have-click-activate-plugins로 이동하여 주소 표시줄에 있는 빨간색 플러그인 아이콘을 클릭하십시오.

Java 애플릿(사용되지 않음)

지원되는 브라우저: Safari, Firefox(2016년까지)

이러한 기능에 사용되던 원래 기술은 플러그인과 동일한 기능을 가진 Java 애플릿이었습니다.  브라우저에서 Java가 작동되고 있으면 이 애플릿을 사용할 수 있습니다.  Java에 대한 지속적인 보안 문제로 인해 애플릿의 개발이 중단되었지만 여전히 지원됩니다. Java가 시스템에서 작동하는지 확인하려면 여기를 클릭하십시오.

 

팔로우

0 댓글

댓글을 남기려면 로그인하세요.