0

Tif reading broken in 3.10?

Hi,

we tried using the new version, 3.10.3 on fedora10 (64bit), and when reading tiff sequences, other than 8bit uncompressed, it gives the message: "Invalid argument: " (and then the filepath), and gives black frames for almost the whole sequence, only a few frames are visible. No error message in the console. Sequences are written out from nuke, tried 8 and 16bit LZW, packbits, deflate compression, only 8bit uncompressed are readable properly. Can someone confirm this, or am I missing something?

Thanks,

Gabor

7件のコメント

  • 0
    Avatar
    Seth Rosenthal

    Gabor, Thanks for the report. I'm sorry you are having trouble with this. I'm at IBC right and don't have a linux box to test this on. When everyone in California wakes up we'll check it out and let you know what we find.

    Cheers,

    Seth

  • 0
    Avatar
    Alan Trombla

    Hi Gabor, yes, confirmed.  Sorry about that.  Seems to be a linux-only problem.  We're investigating and we'll fix that asap.

    Alan

  • 0
    Avatar
    Gabor Toth

    Hi,

    wow thanks for the fast replies! I'm glad to use this great app with such good support. 

    Gabor

  • 0
    Avatar
    Alan Trombla

    Hi Gabor,

    Thanks very much for the kind words!

    And thanks for the report, it's great to get these things early, and this is a bad one, so we'll probably be releasing an updated 3.10 soon.  Meanwhile, here's a (crappy) work-around: the problem is with Unbuffered reads, so if you direct RV to use Buffered reads for tiff files, like this: 

    rv -tiffIOMethod 1 foo.tiff

    It should woork.  We'll keep you posted on the update.

    Cheers,

    Alan

  • 0
    Avatar
    Alan Trombla

    Turns out this is only a factor on some filesystem types (I only see it on a mac filesystem mounted inside a linux VM).  In the next release we'll handle this better.

    Alan

  • 0
    Avatar
    Alan Trombla

    Just an update: RV 3.10.4 is out now, and in the case that the filesystem does not support unbuffered reads, RV now falls back to buffered IO.

    Thanks for the report Gabor!

    Alan

  • 0
    Avatar
    Gabor Toth

    Now it works, remembers the buffered read option. Thanks for the solution!

    Gabor

ログインしてコメントを残してください。