0

Python3 API please.

The latest request for a Python3 version of shotgun_api# libraries I saw on the forums was from 2012.

The Shotgun librarie(s) don't seem to to have any compiled code. (One ***.c file?)

Would it be an issue if we looked at updating an alternate version of the Shotgun Python API to go with Python 3?

Python2.x was scheduled to be deprecated as of 2010 I believe. Several packages are Python3.  It sounds like PySide2 will be moving ahead with deprecating Python2.

Currently there isn't a schedule to allow Python3 compatibility.
We might be able to do it ourselves.  Can anyone think of any reasons why we can't or shouldn't create a Python3 versions of the Python Shotgun API?

 

1 comment

  • 0
    Avatar
    Andrew Cuthbert

    I guess the main reason for keeping with Python 2.X is that all the DCCs used in production still have bundled 2.X interpreters.

    I have actually done some work on a Python3 API, with the goal of adding Blender support - Blender has been on Python3 for a while now.

    As per http://www.vfxplatform.com/ Python2.7 is currently the standard, so until that is updated, I guess there's no push for Python3

Please sign in to leave a comment.