0

RV -prefsPath not always keeping preferences

There is an issue we are having with our RV that it is sometimes not keeping their preferences / login info.

We have our RV run with the -prefsPath argument for our users that points to their own config folder on the network. There is a TweakSoftware folder there with an RV.ini file that has their preferences and login info, so it's pointing to the correct location. The file's creation date is whenever they first ran RV with the argument, and its last edited date is the last time RV was run.

So it doesn't seem to be gathering the information from the RV.ini file all of the time. Sometimes they have their preferences and login info and sometimes it gets lost and they have to write it in again. The program isn't run any differently or from anywhere else to cause conflicts with this file.

Is there anything I can do to get more information on what's going on? Has this happened ever before?

5 comments

  • 0
    Avatar
    Michael Kessler

    Hi Michael,

    What version(s) of RV are your users using, and what version of Windows are you using?

    When the preferences and login info get lost, is that the only preference that is lost, or are more preference settings lost or corrupted (such as cache sizes)?

    Also what kind of filer is your path set to, is it a path mounted over NFS?

    Thanks,

    -Kessler

  • 0
    Avatar
    Michael Wright

    RV version: 7.1
    Windows version: Windows 7

    All preferences are lost, including cache sizes or what ever the user has specified.

    The path is set over a NFS, but that NFS hasn't caused issue before with a lack of connectivity. It does run slow occasionally, but nothing that would prevent a file from being accessed.

    Thanks for the response,

    ~Michael

  • 0
    Avatar
    Michael Kessler

    Hi Michael,

    A bug in Qt was discovered and patched a few versions ago on Linux that matches your description; specifically when multiple RV sessions were closed at the same time on an NFS-mounted path to the preferences file.

    We haven't seen this present itself on Windows; I'm going to track down to see if the patch was applied to the Windows Qt, and if not see if we can build that out.

     

    Thanks,

    -Kessler

  • 0
    Avatar
    Michael Wright

    Thanks so much. For now we'll point the preference file to somewhere that's not a network folder so we don't run into the problem.

  • 0
    Avatar
    Michael Wright

    Hey Kessler,

    We changed the location of where the RV preferences are located to be a directory on their local machine but we still seem to be running into this problem.

Please sign in to leave a comment.